PHP7に移行できました!プラグインでチェックすればよかったのか!!原因はbrBrbr

WordPressはPHP7.0ではまだ使えない・・・と書きましたが、最近ブログが重くてやれないので、PHP7が導入したいなと・・・。

調べてみると、PHP7の導入の障壁となるのは「テーマ」と「プラグイン」に対応していない記述がある場合ということがわかり、

PHP Compatibility Checker

で、対応状況を調べることができるそうです。



ということで、さっそくプラグインをインストールしました。
調べたいバージョンは7.0を選択し、実行するだけ。




今回は初めて使うので、すべてのテーマとプラグインを対象にしました。
その結果として、エラーが出ていたのは、

改行プラグイン brBrbrでした。




これはすべてのブログに導入しており、数年以上更新されていませんから、当然対応していませんよね。
ネットで調べると、修正コードが載っていますので、3行ほど書き換えるとOKでした
 → PHP 7にしたらバグったWordPressプラグイン「brBrbr」のエラーを修正しました – NOROSHI

このおかげで、なんと、なんと、、、

PHP7.0の導入ができました!!

しかも、、、たしかに体感的に早くなりました!!
たったこれだけのことでしたが、、、いやーーー、そうか、、、そうだったんだなと。
エラーが出る時には調べ方があったんだなと思いましたわ。

7.0を導入できずにいる人はお試しあれ!